summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Faure <faure@kde.org>2016-01-12 23:12:22 +0100
committerDavid Faure <faure@kde.org>2016-01-12 23:32:10 +0100
commit4a0985c11ae4ee214036fb650bf0bd0205801018 (patch)
treec511bdb6f74a569a31cc160556d89c30d5f37551
parentd0a2fda6059abda610afe6a8d29b8f5a1c6ae4ae (diff)
downloadlibkolab-4a0985c11ae4ee214036fb650bf0bd0205801018.tar.gz
Fix many warnings: #warning "Inclusion of header files from include/Qt is deprecated."
When using find_package(Qt4), QT_INCLUDES has include/QtCore before include/Qt (as it should be) but somehow leads to -isystem for include/QtCore and -I for include/Qt, so qglobal.h and others are picked up from include/Qt. But we never hit this in KDE because we don't use find_package(Qt4) directly, we let find_package(KDE4) take care of it, somehow it doesn't lead to -isystem.
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06ed7be..07669d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,9 +59,9 @@ include(MacroLogFeature)
find_package(Libkolabxml 1.1 REQUIRED)
macro_log_feature(Libkolabxml_FOUND "Libkolabxml" "Kolab XML Format 3 serializing library" "http://git.kolab.org/libkolabxml/" TRUE "1.0" "Required for reading/writing Kolab XML Objects")
-find_package(Qt4 4.6.0 REQUIRED)
-
if (USE_LIBCALENDARING)
+ find_package(Qt4 4.6.0 REQUIRED)
+
find_package(Libcalendaring)
macro_log_feature(LIBCALENDARING_FOUND "Libcalendaring" "KDE Calendaring-Dependencies Library" "http://git.kolab.org/libcalendaring/" TRUE "" "Required if KDE libraries are not available.")
else()